Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

EO.WebBrowser Custom Handler never goes into Process Options
G
Posted: Thursday, January 5, 2017 11:40:56 PM
Rank: Newbie
Groups: Member

Joined: 12/11/2014
Posts: 7
Hello,

I have implemented a Custom Handler based on your examples. When running, the application goes into the

Code: C#
public override bool Match(Request request)
        {
return true;
}


but never goes into Process

Code: C#
public override void ProcessRequest(Request request, Response response)
        {
}


Instead the LoadFailed event fires with a Generic error.

I downloaded the latest version from your website.

In my constructor, after creating the webBrowser, I call

Code: C#
browser.WebView.LoadUrl("sample://embed");


I have registered
Code: C#
EO.WebEngine.Engine.Default.Options.RegisterCustomSchemes("sample");


Can you help ? Why wouldn't it go into Process if I return true in Match ?

Thanks



eo_support
Posted: Friday, January 6, 2017 7:17:30 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,004
Hi,

There is a short time out for Match for performance reason. So if you set a break point in Match, you will almost certain exceed that time out value and Process will not be called. If you just let it run straight it should work.

Thanks!
G
Posted: Friday, January 6, 2017 10:30:30 AM
Rank: Newbie
Groups: Member

Joined: 12/11/2014
Posts: 7
That worked! Thank you


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.