Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

EO.WebBrowser 17.0.31 The name WebView does not exist in the namespace Options
Andreas
Posted: Wednesday, January 18, 2017 2:46:38 AM
Rank: Newbie
Groups: Member

Joined: 12/2/2015
Posts: 6
With the latest update to EO.WebBrowser 17.0.31 I get the following error:
The name "WebView" does not exist in the namespace "http://schemas.essentialobjects.com/wpf/"

XAML:
xmlns:eo="http://schemas.essentialobjects.com/wpf/"
...
<eo:WebControl Name="EoBrowserControl">
<eo:WebControl.WebView>
<eo:WebView > -->Error
</eo:WebView>
</eo:WebControl.WebView>
</eo:WebControl>

I use the latest Version from NuGet. With the latest 16.* everything works fine.
Eurice
Posted: Wednesday, January 18, 2017 8:12:21 AM
Rank: Advanced Member
Groups: Member

Joined: 12/10/2014
Posts: 90
Hey, same here
eo_support
Posted: Wednesday, January 18, 2017 8:27:31 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,248
Hi,

Did you reference EO.WebBrowser.dll directly in your project? If you only reference EO.WebBrowser.Wpf.dll but not EO.WebBrowser.dll, you will get this error.

Thanks!
Eurice
Posted: Wednesday, January 18, 2017 8:42:43 AM
Rank: Advanced Member
Groups: Member

Joined: 12/10/2014
Posts: 90
Well both are referenced;
I did not had any issue with 2017.0.11.0
eo_support
Posted: Wednesday, January 18, 2017 8:48:35 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,248
Do you have the same problem when you try to compile the TabbedBrowser sample project?
Eurice
Posted: Wednesday, January 18, 2017 8:55:01 AM
Rank: Advanced Member
Groups: Member

Joined: 12/10/2014
Posts: 90
No the project compile fine, but there is no declaration in xaml files.
To be clear :

<eo:WebControl x:Name="webPresentationEO">
<eo:WebControl.WebView >
<eo:WebView UnloadDelay="-1" x:Name="webViewPresentationEO"></eo:WebView>
</eo:WebControl.WebView>
</eo:WebControl>
do not work

but declaring in c# works

public WebView webViewPresentationEO = null;
Andreas
Posted: Wednesday, January 18, 2017 10:02:54 AM
Rank: Newbie
Groups: Member

Joined: 12/2/2015
Posts: 6
I reference
EO.Base
EO.WebBrowser
EO.WebBrowser.Wpf
EO.WebEngine

with 16.2.93 it works fine and the current version doesn't work

the references are added automatically by NuGet
eo_support
Posted: Wednesday, January 18, 2017 11:51:01 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,248
Hi,

We have confirmed this to be an issue on our end. We should have a new build by the end of this week with the fix. We will reply again as soon as the new build is posted.

Thanks!
eo_support
Posted: Thursday, January 19, 2017 5:08:25 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,248
Hi,

This is just to let you know that we have posted build .39 that should address this issue. Please download it from our download page and let us know how it goes.

Thanks!
Andreas
Posted: Friday, January 20, 2017 1:39:38 AM
Rank: Newbie
Groups: Member

Joined: 12/2/2015
Posts: 6
Thank you
now everything works fine.
eo_support
Posted: Friday, January 20, 2017 7:37:34 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,248
Great. Thanks for confirming the fix!
Andreas
Posted: Wednesday, February 15, 2017 3:14:20 AM
Rank: Newbie
Groups: Member

Joined: 12/2/2015
Posts: 6
Hi
with the current Version .64 I get this error again. (Update from .40 to .64 with NuGet)
eo_support
Posted: Wednesday, February 15, 2017 2:31:05 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,248
Hi,

Make sure you add nuget package EO.WebBrowser.Wpf. This is moved into a separate package than the core EO.WebBrowser package. It used to be a part of EO.WebBrowser package.

Thanks!
Andreas
Posted: Thursday, February 16, 2017 8:03:41 AM
Rank: Newbie
Groups: Member

Joined: 12/2/2015
Posts: 6
Hi,
thank you, with this NuGet package it works
eo_support
Posted: Thursday, February 16, 2017 10:08:00 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,248
Great. Thanks for the update!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.