Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

EO PDF Identity-H encoding Options
Marnnson
Posted: Sunday, October 8, 2017 6:53:20 AM
Rank: Newbie
Groups: Member

Joined: 10/8/2017
Posts: 3
Greetings,

I am using EO PDF in my work environment to convert HTML pages to PDF and to modify form fields within existing templates. Lately our clients have been submitting some strange complaints. The form fields within the PDF templates do not recognize the standard Arial font, and certain letters such as b, c, V are missing entirely. While digging around and attempting to find a solution, I've noticed that truetype fonts get encoded with Identity-H and embedded as a subset directly within the PDF. My initial suspicion was that this causes the error, but I'm unsure as of yet. I've tried making sure that my output stream is properly encoded in UTF-8 but this has not yielded any results yet.

Do you have any suggestions or different means of approaching this problem?
eo_support
Posted: Monday, October 9, 2017 8:45:10 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,668
Hi,

Please check if you are using the latest build. EO.Pdf always uses Identity-H with font subset, but older version may not include all the glyph information in the subset, which can cause some characters not being rendered correctly. This issue has been addressed recently.

If the problem still exists with the latest build, please try to isolate the problem into a test project and send the test project to us. See here for more details:

https://www.essentialobjects.com/forum/test_project.aspx

Once we have that we will be happy to investigate further.

Thanks!
eo_support
Posted: Tuesday, October 10, 2017 12:46:22 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,668
We have received the test project and we do not see any problems with the latest version. What version do you use?
Marnnson
Posted: Wednesday, October 11, 2017 3:06:42 AM
Rank: Newbie
Groups: Member

Joined: 10/8/2017
Posts: 3
I'm using the latest version downloaded from your site, version 2017.2.92.0.
eo_support
Posted: Wednesday, October 11, 2017 10:20:53 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,668
We tested this build and it works fine. Can you send us a result PDF file that's wrong?
Marnnson
Posted: Wednesday, October 11, 2017 10:34:08 AM
Rank: Newbie
Groups: Member

Joined: 10/8/2017
Posts: 3
I've just sent you a PDF from our application.


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.