Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

EO.WebBrowser Error code:-351 Options
Fabien
Posted: Monday, February 19, 2018 9:07:23 AM
Rank: Advanced Member
Groups: Member

Joined: 7/21/2014
Posts: 107
Hi,

When you try to navigate to https://www.pagesjaunes.fr the page failed to load with an Error code:-351

The same error happens in your TabbedBrowser as well and the URL works fine in Google Chrome or in others webbrowsers.

Thanks for your help
eo_support
Posted: Wednesday, February 21, 2018 10:36:36 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 20,415
Hi,

This seems to be an issue in the version of the Chromium browser engine we used. Error code -351 is ERR_SPDY_SERVER_REFUSED_STREAM. We expect this issue to be resolved next time we update our Chromium engine version.

Thanks!
Fabien
Posted: Wednesday, February 21, 2018 11:18:37 AM
Rank: Advanced Member
Groups: Member

Joined: 7/21/2014
Posts: 107
Hi,

Ok, not a good a news... Do you have an ETAG for next Chromium engine on EO.WebBrowser? If it's for the end of the year, i think we need to downgrade to previous EO version.
eo_support
Posted: Wednesday, February 21, 2018 2:23:04 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 20,415
Hi,

We have been updating around year end previously. However as we have stream lined our updating process, we maybe able to update twice this year --- even so it will still be a while to our next update though. So in the mean time you may wish to consider downgrading. Please let us know if you need download link to previous versions.

Thanks!
Fabien
Posted: Friday, February 23, 2018 4:53:49 AM
Rank: Advanced Member
Groups: Member

Joined: 7/21/2014
Posts: 107
Hi,

If someone else has the problem, here's how to get around it :
SPDY is a network protocol for HTTP/2, so add this line
Code:
EO.WebBrowser.Runtime.ExtraCommandLineArgs = "--disable-http2";


and voila! Your web engine turn http2 off protocol and use http/1.1 instead and.. that's just works!

This is not a fix but it allows chromium to work as it should...
eo_support
Posted: Friday, February 23, 2018 7:25:43 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 20,415
Ah. Thanks for sharing!
Duka
Posted: Wednesday, June 13, 2018 5:46:49 AM
Rank: Newbie
Groups: Member

Joined: 1/16/2015
Posts: 5
Hi,

I got the same issue at https://www.tui.dk in the Tabbed Browser demo of version 2018.1.91.0
I confirm the solution mentioned by Fabian, thanks.

The code line should be inserted very early in the program:
Code: C#
EO.WebBrowser.Runtime.ExtraCommandLineArgs = "--disable-http2";

E.g. I inserted the code line as the first line in Application_Startup in App.xaml.cs in the Tabbed Browser demo of version 2018.1.91.0
And that solved the issue Angel


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.