Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

[bug] Custom Protocol Scheme's URL modified before being passed into ResourceHandler from Version 18.2.74 onward Options
James
Posted: Wednesday, March 6, 2019 10:38:16 AM
Rank: Advanced Member
Groups: Member

Joined: 2/11/2015
Posts: 104
Starting in Version 18.2.74 and continuing into the most recent versions.
The Custom Protocol Scheme behavior has changed, rendering some usages unavailable, however this isn't indicated in the documentation or in Change logs. I suspect this is a bug.

When a Webpage contains a Custom protocol scheme, such as "App://5349/" the value is translated into an IP Address and the ResourceHandler receives a value of "App://0.0.20.229/" instead.

I am providing a test project which should ease troubleshooting and displays the broken functionality.
the test is self contained so no hosting of pages should be necessary.
the project is setup with nuget to load 18.2.74 however any version after that can be used as well to reproduce the problem.

the EO.WebBrowser.Runtime.AddLicense call is in App.xaml.cs file and needs to be filled.
eo_support
Posted: Friday, March 15, 2019 7:59:44 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,094
Hi,

This issue is caused by code changes in 18.2.74 that would automatically treat any custom protocol scheme as "standard" Url. We have reverted that code changes in build 19.0.83 so now it should revert to old behavior.

Thanks!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.