Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

WPF .NET Application using EO.WebBrowser exits with strange code: “-1073740940” Options
LandTrack Support
Posted: Thursday, July 11, 2019 3:43:14 AM
Rank: Newbie
Groups: Member

Joined: 7/3/2017
Posts: 7
Hello,

We are currently experiencing an issue with our WPF .NET Application that utilises EO.WebBrowser where by the application appears to have completed all tasks successfully (and we log an exit code 0), however the application is actually/finally exiting with code: “-1073740940”.

Is this is issue you've seen before or that has been rectified with an update after version 19.0.69.0 (as that is the version we are using).

Thanks in advance!

Jeremy
eo_support
Posted: Thursday, July 11, 2019 3:23:34 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,607
Hi,

Please check if you have properly destroyed all WebViews in the same thread they were created. This looks like a corruption somewhere and the most common reason for corruption is the objects are not destroyed in the same thread in which they were created.

Thanks!
LandTrack Support
Posted: Monday, September 23, 2019 3:23:39 AM
Rank: Newbie
Groups: Member

Joined: 7/3/2017
Posts: 7
Thank you for your response.

Do you possibly have example code of how this can be achieved and verified?
eo_support
Posted: Monday, September 23, 2019 6:32:14 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,607
Hi,

There is no built-in support on our side for you to verify it. You just have to check it in your code. For example, if you create a WebView, you need to make sure you destroy it in the same thread in which it is created. This is considered general programming techniques so we do not support such issues directly. However if you have already checked everything and still can not find the root cause, you can try to isolate the problem into a test project and send the test project to us. We can check that for you. See here for more information on sending test project to us:

https://www.essentialobjects.com/forum/test_project.aspx

Thanks!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.