Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

Menu's dont' Load under https on Safari Options
Jeff Lundgren
Posted: Monday, April 15, 2019 7:44:18 PM
Rank: Advanced Member
Groups: Member

Joined: 8/22/2007
Posts: 30
In our app, on Safari using https we get javascript errors like:

Quote:
[Error] SyntaxError: Unexpected identifier 'text'. Expected ')' to end an argument list.
(anonymous function) (eo_web.ashx:6)

and

[Error] TypeError: undefined is not a constructor (evaluating 'new EO18346.f.any()')
Global Code (eo_web.ashx:6:12085)

and

[Error] SyntaxError: Unexpected identifier 'text'. Expected ';' after variable declaration.
(anonymous function) (e[/code]o_web.ashx:6)


And the menus are not shown.

Under Chrome or IE it works fine no matter if http or https.

This is version 2018.18.3.46

Again Safari (iOS) + https is a problem, see the script errors above.
eo_support
Posted: Monday, April 22, 2019 3:49:46 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,737
Hi,

Sorry about the delay. We have been trying to reproduce this problem but wasn't successful. Do you have a test page online so that we can access from here?

Thanks!
Jeff Lundgren
Posted: Tuesday, July 30, 2019 12:44:06 AM
Rank: Advanced Member
Groups: Member

Joined: 8/22/2007
Posts: 30
Yes, please look here.
https://temp.cbrestrategicinsight.com
Notice that in http in Safari or any iOS browser (non SSL) it works fine. in SSL in Safari or any iOS browser via https it render, with Javascript errors.
eo_support
Posted: Wednesday, July 31, 2019 6:31:14 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,737
Hi,

Thanks for the test page. We are able to see the problem here but we have not been able to reproduce it in our environment. It appears that there is something in the JavaScript file Safari does not like. Is it possible for you to enable physical script files and then give us FTP access to the test site folder? We will need to modify the JavaScript file in order to pinpoint exactly where the problem is. See here for more information on how to enable physical JavaScript file:

https://www.essentialobjects.com/doc/web/installationanddeployment/deploy.aspx

We will need write permission on the ASPX file as well as the JavaScript files.

Thanks!
Jeff Lundgren
Posted: Tuesday, August 6, 2019 2:34:29 PM
Rank: Advanced Member
Groups: Member

Joined: 8/22/2007
Posts: 30
Thank you!

When I convert it to use physical script files, it works. Not sure why. I think its something regarding the IIS settings in how the dynamic script files are created. However, the physical script files are slightly quicker per the whitepaper, and so this works for us.
eo_support
Posted: Tuesday, August 6, 2019 3:22:11 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,737
That's good news. Glad to hear that it works for you!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.