Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

DownloadUpdated not fired Options
James
Posted: Wednesday, May 17, 2017 12:07:48 PM
Rank: Advanced Member
Groups: Member

Joined: 2/11/2015
Posts: 62
I'm using EO.WebBrowser.Wpf 17.1.42.0, I have regisgtered the BeforeDownload DownloadUpdated and DownloadComplete events and have setup my own custom UI to use display download progress.

However, I never receive any calls in DownloadUpdated.

I do get the BeforeDownload call as well as the DownloadCompleted call and can update my UI accordingly

my BeforeDownload handler sets the e.FilePath, e.ShowDialog = false


I've reviewed the forums to see if there was anything, and the only thing I could find was about receiving a Content-Length header, which I've verified is being sent and received by EO with the download tests I'm running.

I also verified that the DownloadItem.TotalBytes property is already set in BeforeDownload and is still set in DownloadCompleted.
I also tested the download in Chrome and it is able to detect/display the file size and the progress.

I verified that my event handler is registered, it just doesn't seem to get called.

I presume there must be an issue on my end, otherwise I think I'd see other bug reports for this here.
Is there any other considerations I need to make here?
Is this a bug?

eo_support
Posted: Wednesday, May 17, 2017 3:03:53 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,426
If you run our TabbedBrowser sample application, do you get the download percentage updates?
Stefan Koell
Posted: Monday, May 29, 2017 12:50:54 PM
Rank: Advanced Member
Groups: Member

Joined: 12/23/2013
Posts: 39
I see the same issue. It is working in the sample application because of the databinding behavior in WPF. I'm using WinForms and I rely on the DownloadUpdated event. It is not fired although the individual DownloadItem objects do get updated percentage values etc. IMHO the DownloadUpdated event does not get fired when it should.

Regards,
Stefan
eo_support
Posted: Tuesday, May 30, 2017 5:53:26 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,426
Hi,

This is just to let you know that we have found the root issue on our end. This will be addressed in our next build.

Thanks!
Stefan Koell
Posted: Wednesday, May 31, 2017 4:50:15 AM
Rank: Advanced Member
Groups: Member

Joined: 12/23/2013
Posts: 39
Thank you! Looking forward to the new build.

Regards,
Stefan
James
Posted: Wednesday, May 31, 2017 10:42:38 AM
Rank: Advanced Member
Groups: Member

Joined: 2/11/2015
Posts: 62
Thank you, sorry for not responding, I hadn't had a chance to investigate the sample application. Thank you Stefan for looking into it.
eo_support
Posted: Tuesday, June 6, 2017 11:16:34 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,426
Hi,

We have posted a new build that should resolve this issue. You can download the new build from the download page. Please take a look and let us know how it goes.

Thanks!
Stefan Koell
Posted: Tuesday, June 13, 2017 5:10:25 AM
Rank: Advanced Member
Groups: Member

Joined: 12/23/2013
Posts: 39
Thanks for the quick fix! I can confirm the event is now fired properly.

Regards,
Stefan
eo_support
Posted: Tuesday, June 13, 2017 9:19:16 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 19,426
Great. Thanks for confirming the fix!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.