Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

Google chart missing in PDF when generating through server. Options
Uma
Posted: Monday, June 15, 2020 12:52:24 PM
Rank: Newbie
Groups: Member

Joined: 5/13/2020
Posts: 8
Hi,

i have recently upgraded to the latest version of EO.PDF V20 to generate the PDF.

I am facing issue in generating the PDF containing google chart through the server whereas when i tried the same in my local , PDF is generating without any issues .

I have the query why the google chart missing in the PDF while generating through the server but works fine in my local. Mailed the test project for the reference.

eo_support
Posted: Tuesday, June 16, 2020 11:38:31 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,273
Hi,

We did receive your test project however we are not in a position to debug your code for your whenever something doesn't work. So we can only provide you a few general guidelines:

1. It appears that you are trying to callback to the same server using a WebRequest. As a general rule you should avoid this and this does not have anything to do with the HTML to PDF converter. The problem you are seeing may simply because this step failed and you are getting some invalid HTML result;

2. The basic rule for you to use RenderAsPDF is to get the correct output on screen first. In your case, you can comment out RenderAsPDF call and you should get the correct result on screen in your browser. If you do not get correct result on screen, then the problem is not with EO.Pdf (because RenderAsPDF is not called). In that case the problem is usually in your your View/HTML. So you will need to fix that first;

3. If you can't find anything with step 1 or step 2, you can still use EO.Pdf's built-in debugging feature to examine the content of the page that's loaded inside the converter:

https://www.essentialobjects.com/doc/pdf/htmltopdf/debug.aspx

Hope this helps.

Thanks!

Uma
Posted: Tuesday, June 23, 2020 7:33:29 AM
Rank: Newbie
Groups: Member

Joined: 5/13/2020
Posts: 8
Hi ,

I commented RenderAsPDF to ensure correct html is displayed in Screen. But to surprise i am getting the correct html but while render as PDF , google chart is missing .And i believe i generate the PDF using the latest version of EO.PDF (version 20.0 ) even in the server.

Is there any way i could confirm the version during runtime. I have added the license key and EO.PDF dll in the server. Do I need to add anything else addition to this ?

Then can i have the sample project to implement debugging feature.

Thanks!
eo_support
Posted: Wednesday, June 24, 2020 4:52:07 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,273
Hi,

I am not sure what you meant by having sample project to implement debugging feature. The above link already provided the steps and code for you.

The issue would not have anything to do with license.

Thanks!
Uma
Posted: Monday, June 29, 2020 5:20:41 AM
Rank: Newbie
Groups: Member

Joined: 5/13/2020
Posts: 8
Hi ,

Yes I agree there is nothing to do with license. But my actual is , I could able to generate the PDF (with google chart) using EOPDF in my local machine but the same code i deployed in server and tried to generate PDF from the hosted server . Here i find issue where PDF is generated without chart.

As you mentioned i commented out "RenderAsPDFAttribute" and deployed the code in server but to my surprise i could find the HTML without any issues (containing Google Chart). So i believe, the issue is only with PDF.

Do you have any idea where would i have missed ? Please advice.


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.