Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

EO.WebBrowser.WebView.MouseEnter and MouseLeave not working Options
wei
Posted: Thursday, September 10, 2020 6:16:34 AM
Rank: Newbie
Groups: Member

Joined: 5/26/2017
Posts: 2
Hi,

The MouseEnter handler(first time can response) and the MouseLeave handler(never responded) does not work in our project.
And the both handlers worked in version 18.x before. Do you have any suggestions ?

current EO version: 20.1.45
[code=cs]]
eo_support
Posted: Friday, September 11, 2020 10:22:26 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,429
Hi,

This is a known limitation of the current version. In the old version we post a copy of the input message directly to your application's message queue which while triggers MouseEnter/MouseLeave events correctly, it causes other problems since the message has been duplicated. In the new version we no longer duplicate the message and instead raises the corresponding events directly. However this only supports events inside the WebControl. Events that occurs in between controls such as MouseEnter/MouseLeave are not supported yet.

As a workaround, you can try to handle MouseMove on your Window object (I assume you are using WPF) and then check whether the move is from the WebControl or not to trigger your corresponding MouseEnter/MouseLeave handler. Please feel free to let us know if you have problems implementing that.

Thanks


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.