Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

EO.WebBrowser - Printing only results in a blank page Options
Fredrik Aronsson
Posted: Wednesday, April 3, 2019 10:42:35 AM
Rank: Newbie
Groups: Member

Joined: 9/4/2017
Posts: 5
We use EO.WebBrowser to incapsulate a singe-page application (SPA) in another Windows Form application. I'm not entirely sure of how the SPA really works but it has a built in print functionality that opens up a popup (css-popup, not a "real" popup) containing the data that should be printed, like a print preview, with a print button. When the button is pressed, only the data in the popup is being sent to the printer.

The problem is, when used in a EO.WebBrowser, it only results in a blank page being printed. It may finally print what it should if you try it for a couple of times so it isn't faulty 100% of the time. But it works 100% of the time in a regular Chrome browser (or IE/Edge).

I've tried calling the WebViews Print-method but it only printed what can only be described as a screenshot of the css-popup.

Do you have any idea of what is causing this behaviour? I'm using the latest version of EO.WebBrowser (v19.0.97).

/Fredrik
eo_support
Posted: Wednesday, April 3, 2019 12:56:46 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,553
Hi,

We can't think of anything that can cause this problem. Can you try to isolate the problem into a test project and send the test project to us? See here for more details:

https://www.essentialobjects.com/forum/test_project.aspx

Once we have the test project we will be happy to investigate further.

Thanks!
Benoit Martel
Posted: Thursday, October 8, 2020 10:59:17 AM
Rank: Newbie
Groups: Member

Joined: 5/9/2017
Posts: 8
Hi eo_support,

Where are we on this one? We have the same issue in our systems and would like to have this fix (if not already done in a release) as quick as possible.

Regards,

Ben
eo_support
Posted: Thursday, October 8, 2020 3:12:04 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,553
Hi,

We have not been able to investigate this issue because we have never received a test project from the original user. If you have a test project or test Url please send it to us and we will be happy to look further.

Thanks!
Fredrik Aronsson
Posted: Friday, October 9, 2020 2:44:27 AM
Rank: Newbie
Groups: Member

Joined: 9/4/2017
Posts: 5
It still doesnt work. But I cant really provide a test project either since I dont have the source code of the web application. So I guess we´re going nowhere with this.

You can close the ticket.
eo_support
Posted: Friday, October 9, 2020 7:40:15 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,553
If you have page online you can provide us the Url and steps to reproduce the problem. The key is not really a test project, but a way for us to reproduce the problem here. As soon as we can see the problem here, we will start to investigate. We can't investigate an issue we can't see.
Benoit Martel
Posted: Tuesday, October 13, 2020 8:59:47 AM
Rank: Newbie
Groups: Member

Joined: 5/9/2017
Posts: 8
Hi, I just sent a test project using the Contact Us form.

Here's the detail on how to reproduce (it's in the email as well) on how to reproduce:

After clicking on "Start RxConsultaction", a page will load
At the bottom, you will have a link "Pediculosis", click on it.
Without filling informations, go at the botton and click on "Conclude intervention"
The page will show another section, go down again and click on "Print and save".
The result is:
- From Chrome, you will have something printed
- From EO within app, you will have a blank page

The RxConsultactionTestHTML.zip is an example in chrome.
The RxConsultactionTest.zip is the code using EO.Browser.

Please confirm upon reception of the following,

Regards,

Ben
Benoit Martel
Posted: Thursday, October 15, 2020 10:08:53 AM
Rank: Newbie
Groups: Member

Joined: 5/9/2017
Posts: 8
Did you have a chance to look at it?
eo_support
Posted: Thursday, October 15, 2020 3:54:50 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,553
Hi,

Yes. We are able to reproduce the problem. However we are still trying to find out the root cause. As soon as we have an update we will post it here.

Thanks!
Benoit Martel
Posted: Thursday, October 15, 2020 4:01:32 PM
Rank: Newbie
Groups: Member

Joined: 5/9/2017
Posts: 8
Awesome thanks for keeping me posted.
Benoit Martel
Posted: Friday, October 16, 2020 8:09:51 AM
Rank: Newbie
Groups: Member

Joined: 5/9/2017
Posts: 8
Sent you another sample easier to trace and debug.

Regards,

Ben
eo_support
Posted: Friday, October 16, 2020 9:15:53 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,553
Thanks for the sample project. We have what we need now. If we have any update or need anything else we will reply here.
eo_support
Posted: Friday, October 16, 2020 3:55:22 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,553
Hi,

We were able to find out the root of the problem. It would require code change on our end. The fix should be in our next official build, which is scheduled early next month.

We can also create a temporary test build for you to verify the issue on your end (we have already verified it here with your test project). Note that test build is not meant to be used in production since it does not go through the full cycle test a production build goes through. However it can be useful in case we missed something in our fix.

Thanks!
Benoit Martel
Posted: Monday, October 19, 2020 9:17:35 AM
Rank: Newbie
Groups: Member

Joined: 5/9/2017
Posts: 8
Hi!

Awesome. We'll wait for the fix scheduled next month. If you were able to fix it using our test project we are confident it will solve the issue.

Regards,

Ben
eo_support
Posted: Monday, October 19, 2020 1:11:11 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,553
Great. We will reply here again when the new build is available.


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.