Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

cannot set up EO.WebBrowser toolboc for vs2019 Options
jadedota
Posted: Monday, October 19, 2020 3:28:37 AM
Rank: Newbie
Groups: Member

Joined: 10/19/2020
Posts: 2
I installed EO.Total.2020.2.90.0.msi on windows 10,and tried to set up EO.WebBrowser.dll & EO.WebBrowser.WinForm.dll to toolbox of VS2019.
but I got message "there is no webview in EO.WebBrowser.dll"

Do you have any idea what i did wrong?
eo_support
Posted: Monday, October 19, 2020 1:44:12 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,553
Hi,

Where did you get this message?

Thanks!
jadedota
Posted: Monday, October 19, 2020 8:10:14 PM
Rank: Newbie
Groups: Member

Joined: 10/19/2020
Posts: 2
from VS2019
eo_support
Posted: Tuesday, October 20, 2020 9:35:23 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,553
The more information you provide to us, the faster we will be able to help you.

Please provide detailed information about how, when and where you received this message. Do you get this message on the designer surface? Do you get it when you try to compile your application? Do you get it when you start Visual Studio? Is there any other message associated to this message? What happened after you ignore this messages? etc.
jadedota
Posted: Tuesday, October 20, 2020 9:17:43 PM
Rank: Newbie
Groups: Member

Joined: 10/19/2020
Posts: 2
it is the first time that i want to try EO.WebBrowser.dll & EO.WebBrowser.WinForm.dll in my Windows Forms application.

i downloaded & installed EO.Total.2020.2.90.0.msi but i didn't find the EO.WebBrowser WebControl to be added into toolbox.

so i opened a new Windows Forms project in vs2019 and tried to setup EO.WebBrowser.dll & EO.WebBrowser.WinForm.dll as control to toolbox manually.

after i choosed EO.WebBrowser.dll to process to add, it came out the message "there is no webview control in EO.WebBrowser.dll", also the setup of EO.WebBrowser.WinForm.dll happened same problem.

since it failed to add contol to toolbox, i could not continue to try.




eo_support
Posted: Wednesday, October 21, 2020 3:08:51 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,553
Hi,

You do not need to add the WebView component in EO.WebBrowser.dll. You only need to add WebControl in EO.WebBrowser.WinForm.dll.

If you continue to have problems with the toolbox, you can try it without using the toolbox and create our controls in your code directly. See here for sample code:

https://www.essentialobjects.com/forum/postst11890_Object-of-type-39EOWebBrowserWebView39-cannot-be-converted-to-type-39EOWebBrowserWebVie.aspx#50242

Please let us know if you still have problems.

Thanks!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.