Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

EO permissions crash Options
serializer
Posted: Friday, April 9, 2021 10:17:11 AM
Rank: Advanced Member
Groups: Member

Joined: 5/9/2016
Posts: 83
If I create a standard user and turn on UAC the EO.WebBrowser crashes. How can we workaround this?
eo_support
Posted: Friday, April 9, 2021 3:03:41 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,858
We tested this here and it works fine. So you will need to find out exactly what's causing the crash. Do you get any kind of exception?
serializer
Posted: Tuesday, April 20, 2021 10:28:17 AM
Rank: Advanced Member
Groups: Member

Joined: 5/9/2016
Posts: 83
I have found that this is related to manifest settings.

When using <requestedExecutionLevel level="asInvoker" uiAccess="true"> AND sign it we get crashes and strange behavior. When changing to uiAccess="false" it works.


However, this false setting creates other issues for us so we rather have your tool working with "true" option. Can you find the reason why?
eo_support
Posted: Tuesday, April 20, 2021 4:09:42 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,858
But what error are you getting? How does your application crash? And how do you know the crash is related to our product?
serializer
Posted: Thursday, April 22, 2021 7:31:14 AM
Rank: Advanced Member
Groups: Member

Joined: 5/9/2016
Posts: 83
It hangs (maybe crashes later). Here is the combination that makes it hang:

- Using manifest setting: <requestedExecutionLevel level="asInvoker" uiAccess="true">
- Signing it
- UAC is on
- Standard (non admin user)


So, it has to be a standard user where UAC is on running the sample exe and it hangs.


We have emailed you link to sample project so you can see for yourself.
eo_support
Posted: Thursday, April 22, 2021 11:34:02 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,858
Hi,

We tested your sample here and it works fine.

Where does it hang? You can't just ask us to investigate because your application hangs or crashes. You have to tell us exactly where and how it hangs or crashes and you have to explain why you believe this is related to our product. Only when these initial analysis indicates the issue falls into/originates from our code can we do anything about it.

Thanks!
serializer
Posted: Thursday, April 22, 2021 11:48:17 AM
Rank: Advanced Member
Groups: Member

Joined: 5/9/2016
Posts: 83
See the video here: https://www.screencast.com/t/WImd0uK7z5

So, it simply does not show. Only the license warning. As you see there is no specific code behind.

I think when you test you are either not testing as a Standard user (with UAC on) or you are not running from a program files like we do.
eo_support
Posted: Thursday, April 22, 2021 3:33:40 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,858
Hi,

We tested this and it works fine here. You can run some custom test on your system and see if it reveals something. We will send you detailed instruction through private message on how to run custom test.

Thanks!
serializer
Posted: Friday, April 23, 2021 6:49:19 AM
Rank: Advanced Member
Groups: Member

Joined: 5/9/2016
Posts: 83
Ok, we have the test now. Let us know if your need more info.
eo_support
Posted: Monday, April 26, 2021 2:21:35 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,858
Hi,

We have sent a new build to you. Please see your private message for details.

Thanks!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.