Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

Failed to start image manager Options
Sören
Posted: Thursday, September 16, 2021 10:22:01 AM
Rank: Member
Groups: Member

Joined: 5/14/2020
Posts: 19
I have a problem with the EO.WebBrowser for .NET.

For a customer I get an error when starting our application that uses the WebBrowser:

Failed to start image manager

at EO.Base.Runtime.rpjo(Object ltg, Exception lth, Boolean lti)
at EO.Internal.lwph.dczf.waas()
at EO.Internal.lwph.sjvk()
at EO.Internal.lwph.sjvj(Boolean& nmk, lwpk[] nml, String nmm, String nmn)
at EO.Internal.lwph.waas(lwpk[] nmh, String nmi, String nmj)
at EO.Internal.lwpi.waas(String nrl, String nrm)
at EO.Internal.nydq.cnvj()
at EO.Internal.nydq.huri.vaty()
at EO.Internal.lwku.vysk(Action lul)
at EO.Internal.nydq.mnfi(WindowsIdentity fg)
at EO.WebEngine.Engine.Start(WindowsIdentity user)
at EO.WebEngine.Engine.Start()
at EO.Internal.nydq.cnvi()
at EO.Internal.egex..ctor(WebView p)
at EO.WebBrowser.WebView.nror()
at EO.WebBrowser.WebView.nror(IntPtr fp, Boolean fq)
at EO.WebBrowser.WebView.Create(IntPtr hWnd)
at EO.Wpf.WebViewHost.frhd.kvtx()


After my research on the internet, I would guess that the cause of the error is that the eowp.exe cannot be started.

The customer uses AppLocker, but has EssentialObjects enabled as the publisher and our application has been working there. Only after updating the application the above error occurs.

The application uses version 21.1.67 of EssentialObjects. The version of eowp.exe, however, is 20.3.34. This file can also be executed via the command line. I get the following output

eowp.exe
This program is a part of EO.Total.
AddMissingAPIModule:kernel32.dll
AddMissingAPIModule:user32.dll
AddMissingAPIModule:d3d11.dll
AddMissingAPIModule:dxgi.dll
AddMissingAPIModule:dxva2.dll
AddMissingAPIModule:dwrite.dll
AddMissingAPIModule:shell32.dll
AddMissingAPIModule:dbghelp.dll
AddMissingAPIModule:msdmo.dll


The following details are output about the error:

Exception:
System.Exception: Failed to start image manager
bei EO.Internal.lwph.dczf.ytyw()
bei EO.Internal.lwph.dczf.waas()

Begin_Block_1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End_Block_1

Begin_Block_2
gAAAAJ+tnbcQQJhVzDUaCqRqQ1DlorF4Bc1/bShTAQCyqwnQPYisQS4XLR28yp8MXgG8F5M0VFla
XzvYhE5kn2nPLnkWEXXinGfeYqLzX5RPiN7YzKonywrs+RP/YWMjC4QvQMSnVkKagFKAP+lMSTUd
a+3mSeIqTDNVDOFNqWAH8JTbEAAAAHo2/I4rnACJ6HtYRb7+bN0QAAAAh9QxqjN/x2nCI1jp/Vse
UA==
End_Block_2


eo_support
Posted: Thursday, September 16, 2021 3:00:23 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 23,072
Hi,

The version of eowp.exe MUST match the version of the DLL. So you can try to replace the wrong eowp.exe with the correct one first and see if it works for you.

Alternatively, you can also change your code to automatically create eowp.exe by calling this method:

https://www.essentialobjects.com/doc/eo.base.runtime.initworkerprocessexecutable.aspx

Thanks!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.