Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

Troubleshooting design time error Options
eo_support
Posted: Wednesday, February 20, 2008 1:14:37 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,925
Very often after you have upgraded to a new version or when you open an old project you would get the following error message in Visual Studio:

"Unable to initialize external designer module, please check the installation and verify that EO.Web.dll in your bin folder is the same as the installed one."

This is caused by a version mismatch between the version used by your project (for example, the version of EO.Web.dll in your bin folder) and the version installed on your machine. Thus you can first check whether our product is indeed installed on your machine, if it does, check whether the installed version is the same as the one that your project uses.

To check whether our product is installed on your machine, check for "EO.Web Controls xxxx.x" and "EO.WinForm Controls xxxx.x" program group, where "xxxx.x" is the release, for example, "2007.2", "2008.1". You can also check whether you have our product in your "Add/Remove Programs" list.

Once you are sure our product is installed, check the version number of the core DLLs. For example, for EO.Web Controls, check the version number of EO.Web.dll. Check the version of the DLL found in the install location and the DLL found in your project's bin folder. For example, for EO.Web Controls, the default install location is "c:\Program Files\Essential Objects\EO.Web Controls xxxx.x". Thus you should check the version of EO.Web.dll found in that folder. For EO.Web Controls, there are two DLLs, one for ASP.NET 1.1, the other for ASP.NET 2.0 and above. The two not only resides in different directories, but are also distinguished by the last digits of the version number. The last digit is always "1" for the ASP.NET 1.1 build, and "2" for ASP.NET 2.0 build. For example, version "5.0.10.1" is for ASP.NET 1.1, "5.0.10.2" is for ASP.NET 2.0.

When compare the version number, compare the first three numbers only, for example "5.0.10". The last number is not for you to choose ---- if your app runs on ASP.NET 1.1, you must use the ASP.NET 1.1 build, if your app runs on ASP.NET 2.0, you must use ASP.NET 2.0 build. Usually your development tool determines the ASP.NET version. For example, Visual Studio 2003 uses ASP.NET 1.1, Visual Studio 2005/2008 uses ASP.NET 2.0.

On the contrary, EO.WinForm Controls only has one version of EO.WinForm.dll, the same DLL works for all .NET versions.

To resolve a version mismatch, you can either reinstall the version that your project uses, or update your project to use the new version. If you wish to reinstall the version that your project uses but the version is no longer available on our download page, please contact us. We will be happy to provide you download link if you are a licensed user. Otherwise unfortunately we will not be able to provide download link to an old version to you.

To update your project reference, switch to "Solution Explorer" in Visual Studio, expand "Reference", then delete our DLL from there and re-add the correct one (from our installation folder), then restart Visual Studio.

If the problem persists, try to run the page and see if it gives you a more detailed error message. If that does not give you a clear indication of what's wrong, please contact us and we will be happy to take a look.





You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.