Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

[19.x] Focus moving from wpf controls into browser doesn't invoke native lostfocus events as exp Options
James
Posted: Wednesday, March 6, 2019 1:30:12 PM
Rank: Advanced Member
Groups: Member

Joined: 2/11/2015
Posts: 104
I have already provided a valid test project for this, all that is needed is to use the latest version of the EO WebBrowser library to reproduce the issue. I have verified this is affecting 19.0.69 and 19.0.56, but does not affect versions from the 2018 series.

In the test project provided, after launching the project you can modify the url from the default to another url, such as https://www.essentialobjects.com/ then press tab.

In the test project, this moves the focus from the TextBox to the WebBrowser, however the TextBox never invokes the LostFocus event in this case.

If you use any version prior to 2019, this works without exception.

It should be noted that changing focus from the TextBox to another Focusable WPF control still invokes LostFocus, so this is limited to switching focus into the browser.
eo_support
Posted: Friday, March 15, 2019 8:22:00 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,094
Hi,

This issue should be resolved in build 19.0.83. Please let us know if you still see any problems.

Thanks!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.