Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

Webbrowser jquery error after updating Options
Louis
Posted: Wednesday, November 25, 2020 2:11:13 AM
Rank: Member
Groups: Member

Joined: 6/20/2016
Posts: 29
After updating the browser of one of my older projects to the latest version of EO webbrowser, all my evalscripts with jquery are failing with the error "Uncaught ReferenceError: $ is not defined'" ... almost as if jquery is not loaded. I've replicated this with some of my other projects too.

Is there a particular flag that needs to be set to get jquery working? Or any insight you can provide to point me in the right direction?

The old version was 18.x.x, not 100% sure...
eo_support
Posted: Wednesday, November 25, 2020 10:13:24 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 22,618
Hi,

This could be you are using an older version of JQuery that doesn't work with newer version of the Chromium browser engine. Please try to run the same page in Google Chrome and see if you get the same error. If the problem also occurs with Google Chrome, then obviously you will need to change your page.

If the problem only occurs with EO.WebBrowser, please try to isolate the problem into a test page and send the test page to us. Once we have that we will see what we can find. See here for how to send test file to us:

https://www.essentialobjects.com/forum/test_project.aspx

Thanks!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.