Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

v2021 of EO.webbrowser crashes every time Options
richard sheldon
Posted: Thursday, July 22, 2021 10:53:16 AM
Rank: Newbie
Groups: Member

Joined: 12/3/2018
Posts: 3
Ive just downloaded the latest version off your website for evaluation.

I used to use 2015 version.

Two things, one this version is horrendously slow at rendering html5 web pages.

Secondly, So I am embedding a webbrowser into my c# winforms project and get

DOM EXCEPTION: unable to decode audio data

this happens everytime it tries to load the page

any ideas?



Jack Cheng
Posted: Thursday, July 22, 2021 10:55:55 AM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 23,036
Hi,

Please try to enable proprietary video/audio codecs and see if it works for you:

https://www.essentialobjects.com/doc/webbrowser/advanced/html5.aspx

Thanks!
richard sheldon
Posted: Thursday, July 22, 2021 12:09:47 PM
Rank: Newbie
Groups: Member

Joined: 12/3/2018
Posts: 3
Hi

Ive added this line :


EO.WebEngine.Engine.Default.Options.AllowProprietaryMediaFormats();

Please note, that in the 2015 version, I always used this line ( or equivalent) and the error was intermitent

I cant tell yet if its fixed it.

the next huge issue I have is, since putting on version 2021 the performance has nose dived

Its like, incredibly slow at rendering graphics in an html5 page

any ideas on this too?

cheers
richard
Jack Cheng
Posted: Thursday, July 22, 2021 1:13:13 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 23,036
Hi,

We can't tell you exactly what causing the difference --- these are two different versions of the browser engine that are years apart. So there are 10s of millions line of code changes between these two versions.

A quick test for you is to try to load the same page in Google Chrome browser and see if it works for you. If it works smoothly in Google Chrome but works very slow in EO.WebBrowser, then you can try to download the x64 build from our download page and see if it works better for you. If the x64 build still does not work, then please PM us the page Url so that we can check it here to see what we can find.

If the page is also slow in Google Chrome, then it means there is something you are not doing properly. It could be a feature that was supported by older version of the browser engine but no longer supported in the new version. In that case you will have to modify your page to address the issue.

Thanks
richard sheldon
Posted: Friday, July 23, 2021 6:17:44 AM
Rank: Newbie
Groups: Member

Joined: 12/3/2018
Posts: 3
So Im trying to make sure this is true but dont know where to set it. It appears, setting right at the start of my code before any webview is created doesnt work

EO.WebEngine.Engine.Default.Options.DisableGPU = true
EO.WebEngine.Engine.Default.Options.DisableGPU = false

Ive tried both, neither make any difference. Can you tell me how I know if its enabled or not and how I properly use it

thanks





Jack Cheng
Posted: Friday, July 23, 2021 12:54:30 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 23,036
Hi,

You can go to your task manager to look for the command line of rundll.exe (or eowp.exe). You will see several of them, one of them will have the following command line:

Code:
--enable-speach-input ....other arguments.... --disable-gpu


When GPU is not disabled (default), you won't see the "--disable-gpu" part.

Thanks!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.