Logo
My Account |  Site Map | Contact Us  
Welcome Guest Search | Active Topics | Sign In | Register

EO WebBroser can't log in to google Options
kickstation
Posted: Tuesday, December 10, 2019 7:22:38 AM
Rank: Newbie
Groups: Member

Joined: 4/3/2019
Posts: 6
Lately the webbrowser can't log to google services anymore. After providing username and password google just brings up a "You are trying to sign in from a browser or app that doesn't allow us to keep your account secure. Try using a different browser." message. Any suggestions? I tried changing user agent, but that didn't help.
Thanks
RobotGizmo
Posted: Tuesday, December 10, 2019 11:41:44 AM
Rank: Newbie
Groups: Member

Joined: 6/13/2019
Posts: 7
We're unfortunately having the same issue with some Google services using EO.WebBrowser.
eo_support
Posted: Tuesday, December 10, 2019 3:20:26 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,938
Hi,

What version of EO.WebBrowser are you using? We tested with the latest build with Gmail here and it seems to work fine.

Thanks!
RobotGizmo
Posted: Tuesday, December 10, 2019 3:39:25 PM
Rank: Newbie
Groups: Member

Joined: 6/13/2019
Posts: 7
I'm using the latest build in NuGet and trying it with Google Calendar. Maybe I have some options enabled that are preventing the login. Let me see if I can get a repro project going. Just for the record, this is the issue I'm running into:

https://magpcss.org/ceforum/viewtopic.php?f=10&t=16717
kickstation
Posted: Tuesday, December 10, 2019 11:52:37 PM
Rank: Newbie
Groups: Member

Joined: 4/3/2019
Posts: 6
we're using 19.0.97.0, so with the latest supported chromium engine
kickstation
Posted: Wednesday, December 11, 2019 4:33:24 AM
Rank: Newbie
Groups: Member

Joined: 4/3/2019
Posts: 6
updating to latest build didn't help. still same error message from google:
"You are trying to sign in from a browser or app that doesn't allow us to keep your account secure. Try using a different browser."
kickstation
Posted: Wednesday, December 11, 2019 4:37:24 AM
Rank: Newbie
Groups: Member

Joined: 4/3/2019
Posts: 6
i am reffering to log in via this link https://accounts.google.com/signin
eo_support
Posted: Wednesday, December 11, 2019 1:56:20 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,938
Hi,

We tested it here with our TabbedBrowser sample application here and it worked fine. Can you try using TabbedBrowser sample application and see if it works for you?

Thanks!
RobotGizmo
Posted: Thursday, December 12, 2019 9:25:35 AM
Rank: Newbie
Groups: Member

Joined: 6/13/2019
Posts: 7
This is crazy but it looks like it's working here now too. This has been an issue for weeks, maybe Google changed something on their end?
eo_support
Posted: Thursday, December 12, 2019 2:12:30 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,938
Hi,

It could be. We did hear this from another user once before but the issue went away by itself. So it does appear to be Google doing something on their end.

Thanks!
Duka
Posted: Wednesday, December 18, 2019 3:41:58 AM
Rank: Newbie
Groups: Member

Joined: 1/16/2015
Posts: 8
Hi,
I am having the same issue with https://accounts.google.com/signin
I get the following message when signing in: "This browser or app may not be secure. Learn more
Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in."
And the "Learn More" link navigates to: https://support.google.com/accounts/answer/7675428?hl=en
I am using the TabbedBrowser sample from V2019.2.91.0 (downloaded today).
Note: The issue only occurs when not signed in at Google in advance. If signed in, then you first need to sign out in order ro reproduce the issue.
Kind Regards, Duka
eo_support
Posted: Wednesday, December 18, 2019 11:14:43 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,938
Hi,

We are not able to reproduce this issue on our end. It could be regional and it could have to do Chromium version we use. We are working on a new release that uses a much newer version of the Chromium browser engine. The new release should be out in January. One that release is out you can try it and see if it resolves the issue.

Thanks
Duka
Posted: Thursday, December 19, 2019 2:22:49 AM
Rank: Newbie
Groups: Member

Joined: 1/16/2015
Posts: 8
Hi,

Ok, we will try again, when we get the new version with the new Chromium engine.
Thank you for the fast reply.

Kind Regards, Duka
Louis
Posted: Thursday, January 2, 2020 4:30:19 AM
Rank: Member
Groups: Member

Joined: 6/20/2016
Posts: 28
I can confirm this same issue has been happening to me for the past few months, including with the latest version. I discovered a workaround today that I thought I'd share... if you use a custom user agent (a mobile one in my case) then it works... so far.
Duka
Posted: Thursday, January 16, 2020 9:09:24 AM
Rank: Newbie
Groups: Member

Joined: 1/16/2015
Posts: 8
Hi,
I can confirm that workaround for "https://accounts.google.com/signin" works. I used the latest Firefox user agent string.
Thank a lot, Louis, for sharing the workaround :-)
Kind Regards, Duka
eo_support
Posted: Thursday, January 16, 2020 5:57:39 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,938
Thanks for sharing. We have posted our new 2020 release. Please try the new release without using custom user agent and see if it works for you.
yvesm
Posted: Friday, January 24, 2020 11:58:40 AM
Rank: Advanced Member
Groups: Member

Joined: 12/1/2014
Posts: 55
Just to confirm that I am also getting this problem with the TabbedBrowser sample and the latest version posted 24 JAN
eo_support
Posted: Friday, January 24, 2020 12:34:59 PM
Rank: Administration
Groups: Administration

Joined: 5/27/2007
Posts: 21,938
Hi,

We are aware of this issue and there may not be much we can do --- it appears that Google is trying to block "embedder" on purpose. If we have any update we will post again.

Thanks!


You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.